`
linxiaoty
  • 浏览: 12041 次
  • 性别: Icon_minigender_1
  • 来自: 广州
最近访客 更多访客>>
社区版块
存档分类
最新评论

sicily1122. Prerequisites?

阅读更多

1122. Prerequisites?

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

 

Freddie the frosh has chosen to take k courses. To meet the degree requirements, he must take courses from each of several categories. Can you assure Freddie that he will graduate, based on his course selection?

 

Input

Input consists of several test cases. For each case, the first line of input contains 1 ≤ k ≤ 100, the number of courses Freddie has chosen, and 0 ≤ m ≤ 100, the number of categories. One or more lines follow containing k 4-digit integers follow; each is the number of a course selected by Freddie. Each category is represented by a line containing1 ≤ c ≤ 100, the number of courses in the category, 0 ≤ r ≤ c, the minimum number of courses from the category that must be taken, and the c course numbers in the category. Each course number is a 4-digit integer. The same course may fulfil several category requirements. Freddie's selections, and the course numbers in any particular category, are distinct. A line containing 0 follows the last test case.

Output

For each test case, output a line containing "yes" if Freddie's course selection meets the degree requirements; otherwise output "no."

Sample Input

3 2
0123 9876 2222
2 1 8888 2222
3 2 9876 2222 7654 
3 2
0123 9876 2222
2 2 8888 2222
3 2 7654 9876 2222
0

Sample Output

yes
no

 

题目分析:水题一道,适用于刚学编程的人来做,选择适当的数据结构就行啦。

 

参考代码:

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <set>
using namespace std;

int main()
{
    int k, m;
    int scourse;
    int c, r;
    int temp;
    while (scanf("%d", &k) && k != 0)
    {
        scanf("%d", &m);
        set<int> s;
        for (int i = 0; i < k; ++ i)
        {
            scanf("%d", &scourse);
            s.insert(scourse);
        }
        bool havepass = true;
        for (int i = 0; i < m; ++ i)
        {
            scanf("%d%d", &c, &r);
            int num = 0;
            for (int j = 0; j < c; ++ j)
            {
                scanf("%d", &temp);
                if (havepass == false)
                {
                    continue;
                }
                if (s.count(temp))
                {
                    ++ num;
                }
            }
            if (num < r)
            {
                havepass = false;
            }
        }
        if (havepass)
        {
            printf("yes\n");
        }
        else
        {
            printf("no\n");
        }
    }
}                                 

 

0
0
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics