`
linxiaoty
  • 浏览: 12012 次
  • 性别: Icon_minigender_1
  • 来自: 广州
最近访客 更多访客>>
社区版块
存档分类
最新评论

sicily1007. To and Fro

阅读更多

1007. To and Fro

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is "There's no place like home on a snowy night" and there are five columns, Mo would write down t o i o y h p k n n e l e a i r a h s g e c o n h s e m o t n l e w x Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character `x' to pad the message out to make a rectangle, although he could have used any letter. Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as toioynnkpheleaigshareconhtomesnlewx Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.

Input

There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2 . ..20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

Output

Each input set should generate one line of output, giving the original plaintext message, with no spaces.

Sample Input

5
toioynnkpheleaigshareconhtomesnlewx
3
ttyohhieneesiaabss
0

Sample Output

theresnoplacelikehomeonasnowynightx
thisistheeasyoneab

 

题目分析:字符串处理 不解释

 

参考代码:

#include<iostream>
#include<string>
using namespace std;

int main()
{
    int t;
    int num;
    string s;
    string str[1000];
    string a;
    while (true)
    {
        cin  >> num;
        if (num != 0)
        {
            
            cin >> s;
            a.clear();
            int length = s.size();
            int temp = length / num;
            if (temp % 2 == 0)
            {
                int sum = length / (2 * num);
                for (int i = 0; i < sum; ++ i)
                {
                    str[i].assign(s, 2 * num * (i), 2 * num);
                }
                for (int k = 0, j = 2 * num - 1; k < j; ++ k, -- j)
                {
                    for (int i = 0; i < sum; ++ i)
                    {
                        a.append(1, str[i][k]);
                        a.append(1, str[i][j]);
                    }
                }
            }
            else
            {
                int sum = length / (2 * num);
                for (int i = 0; i < sum; ++ i)
                {
                    str[i].assign(s, 2 * num * (i), 2 * num);
                }
                for (int k = 0, j = 2 * num - 1; k < j; ++ k, -- j)
                {
                    for (int i = 0; i < sum; ++ i)
                    {
                        a.append(1, str[i][k]);
                        a.append(1, str[i][j]);
                    }
                    a.append(1,s[length - num + k]);
                }
            }
            cout << a << endl;
        }
        else
        {
            break;
        }
    }
}                                 

 

0
0
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics